[Firewall] Issues with legacy plugin support

Philip A. Prindeville philipp_subx at redfish-solutions.com
Fri Jan 2 01:02:50 CET 2009


I'm looking at both 1.8.8o and 1.9.0rc5, and seeing:

# Required for legacy plugins:
PLUGIN_PATH="$PLUGIN_BIN_PATH"


yet every place that PLUGIN_PATH gets used in a plugin, it's used as:

50ipv6-over-ipv4.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50linuxigd.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50multiroute.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50racoon-ipsec-vpn.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50sip-voip.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50ssh-brute-force-protection.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
50transparent-dnat.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"
60traffic-shaper.plugin:  CONF_FILE="$PLUGIN_PATH/$PLUGIN_CONF_FILE"



So give that fact, shouldn't PLUGIN_PATH be set to $PLUGIN_CONF_PATH 
instead???

-Philip



More information about the Firewall mailing list