[Firewall] Dependency on coreutils-8.16 on Gentoo

Mick michaelkintzios at gmail.com
Sat Sep 14 16:34:51 CEST 2013


Thanks!  It all makes sense now.  :-)

On Saturday 14 Sep 2013 14:31:31 Ferenc Erki wrote:
> hi Mick,
> 
> there is a bug with seq in coreutils-8.20 which can cause problems with
> some functions in Arno's iptables firewall. For more details, please see
> the following links:
> - original thread on this list starts
> here<http://rocky.eld.leidenuniv.nl/pipermail/firewall/2013-April/002288.ht
> ml> - Gentoo bug <https://bugs.gentoo.org/show_bug.cgi?id=448716>
> 
> The bug has been resolved
> upstream<http://git.savannah.gnu.org/cgit/coreutils.git/diff/?id=76f606a954
> 4bd67629bd4766ff6efe8bf42b20d9>and starting from
> sys-apps/coreutils-8.20-r2, the fix is already available in Gentoo.
> 
> Because of the above, the newer net-firewall/arno-iptables-firewall ebuilds
> are depending on the unaffected versions of sys-apps/coreutils (which is
> any version before 8.20 or after 8.20-r1).
> 
> Personally I use net-firewall/arno-iptables-firewall-2.0.1d-r2 with
> sys-apps/coreutils-8.20-r2 currently as this combination is the closest to
> the stable versions while avoiding the above issue.
> 
> I hope this info helps you to understand the situation better. Should you
> have any further questions or issues with using Arno's iptables firewall on
> Gentoo, don't hesitate to ask here or file bugs in Gentoo's Bugzilla! :)
> 
> p.s.: curetuils-8.21 is getting stabilized in
> Gentoo<https://bugs.gentoo.org/show_bug.cgi?id=467186>(since a while
> now..) and I'm waiting for it to stabilize
> arno-iptables-firewall-2.0.1d-r2 (although technically it may be possible
> to stabilize it now, I don't think it's a good idea to force stable users
> to downgrade to coreutils-8.16 just because of the seq issue).
> 
> FErki
> 
> 
> 2013/9/14 Mick <michaelkintzios at gmail.com>
> 
> > Hi All,
> > 
> > Is there a reason that arno's version 2.0.1d-r2 on Gentoo, depends on
> > sys- apps/coreutils-8.16 instead of sys-apps/coreutils-8.20 ?  I keep
> > getting this
> > whenever I run emerge:
> > =====================
> > 
> > # emerge -uaDv world
> > 
> > These are the packages that would be merged, in order:
> > 
> > Calculating dependencies... done!
> > 
> > Total: 0 packages, Size of downloads: 0 kB
> > 
> > WARNING: One or more updates have been skipped due to a dependency
> > conflict:
> > 
> > sys-apps/coreutils:0
> > 
> >   (sys-apps/coreutils-8.20::gentoo, ebuild scheduled for merge) conflicts
> > 
> > with
> > 
> >     <sys-apps/coreutils-8.20 required by (net-firewall/arno-iptables-
> > 
> > firewall-2.0.1d-r2::gentoo, installed)
> > 
> > --
> > Regards,
> > Mick
> > 
> > _______________________________________________
> > Firewall mailing list
> > Firewall at rocky.eld.leidenuniv.nl
> > http://rocky.eld.leidenuniv.nl/mailman/listinfo/firewall
> > Arno's (Linux IPTABLES Firewall) Homepage:
> > http://rocky.eld.leidenuniv.nl

-- 
Regards,
Mick
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part.
URL: <http://rocky.eld.leidenuniv.nl/pipermail/firewall/attachments/20130914/64369082/attachment.pgp>


More information about the Firewall mailing list